Account Registration Issues
Incident Report for DVD Locker
Resolved
This incident has been resolved. Affected customers have been contacted by email.
Posted Apr 29, 2022 - 19:00 UTC
Investigating
There is an issue with customers creating their account. We are looking in to the issue.
Posted Apr 29, 2022 - 15:42 UTC
This incident affected: DVD Locker Account Services.